GitHub Advisoryadvisory · Packagist
GHSA-gjvc-55fw-v6vq Wallabag user can delete own API client unintentionally
MEDIUM
Official page ↗
- Aliases
- CVE-2023-4455
- Ecosystem
- Packagist
- Packages
- wallabag/wallabag
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-08-21
Affected packages
• Packagist wallabag/wallabag: >= 2.0.0-alpha.1, < 2.6.3 → fixed in 2.6.3
Description
Description
wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily delete API key via `/developer/client/delete/{id}`
This vulnerability has a CVSSv3.1 score of 6.5.
You should immediately patch your instance to version 2.6.3 or higher if you have more than one user and/or having open registration.
Resolution
This action is now doable only via POST method, which ensures that we can't do it via a 3rd-party website.
Credits
We would like to thank @tht1997 for reporting this issue through huntr.dev.
Reference: https://huntr.dev/bounties/5ab1b206-5fe8-4737-b275-d705e76f193a/
Related
Alias · CVE (1)
- CVE-2023-4455 Cross-Site Request Forgery (CSRF) in GitHub repository wallabag/wallabag prior to 2.6.3. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness