GitHub Advisoryadvisory · Packagist
GHSA-gmff-vcv6-mmfr Pimcore CSRF Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2018-14057
- Ecosystem
- Packagist
- Packages
- pimcore/pimcore
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2023-07-25
Affected packages
• Packagist pimcore/pimcore: < 5.3.0 → fixed in 5.3.0
Description
Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the `X-pimcore-csrf-token` anti-CSRF token only in the "Settings > Users / Roles" function.
Related
Alias · CVE (1)
- CVE-2018-14057 Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-14057 advisory
- https://www.exploit-db.com/exploits/45208 web
- https://www.sec-consult.com/en/blog/advisories/sql-injection-xss-csrf-vulnerabilities-in-pimcore-software web
- http://packetstormsecurity.com/files/148954/Pimcore-5.2.3-CSRF-Cross-Site-Scripting-SQL-Injection.html web
- http://seclists.org/fulldisclosure/2018/Aug/13 web