GitHub Advisoryadvisory · Maven

GHSA-gq7g-vg2q-jvq3 Apache Syncope has an Improper Isolation or Compartmentalization vulnerability

HIGH Published 2026-05-26 Modified 2026-06-30 Official page ↗
Aliases
CVE-2026-42782
Ecosystem
Maven
Packages
org.apache.syncope.core:syncope-core-spring
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-653
Reviewed
2026-06-30

Affected packages

• Maven org.apache.syncope.core:syncope-core-spring: >= 3.0.0-M0, <= 3.0.16 (no fix yet) • Maven org.apache.syncope.core:syncope-core-spring: >= 4.0.0-M0, < 4.0.6 → fixed in 4.0.6 • Maven org.apache.syncope.core:syncope-core-spring: >= 4.1.0-M0, < 4.1.1 → fixed in 4.1.1

Description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

Related

Alias · CVE (1)

  • CVE-2026-42782 Improper Isolation or Compartmentalization vulnerability in Apache Syncope. vulnerability

Weakness · CWE (1)

  • CWE-653 Improper Isolation or Compartmentalization weakness

References