GitHub Advisoryadvisory · Packagist
GHSA-gq9f-8rj4-w7jc Moodle CSRF risk in admin preset tool management of presets
HIGH
Official page ↗
- Aliases
- CVE-2024-34001
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2024-06-04
Affected packages
• Packagist moodle/moodle: >= 4.3.0, < 4.3.4 → fixed in 4.3.4
• Packagist moodle/moodle: >= 4.2.0, < 4.2.7 → fixed in 4.2.7
• Packagist moodle/moodle: < 4.1.10 → fixed in 4.1.10
Description
Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.
Related
Alias · CVE (1)
- CVE-2024-34001 Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness