GitHub Advisoryadvisory · npm

GHSA-gv5r-9gxr-v74w Bootstrap Multiselect Vulnerable to CSRF and Reflective XSS via Arbitrary POST Data

MEDIUM Published 2025-05-13 Modified 2026-02-26 Official page ↗
Aliases
CVE-2025-47204
Ecosystem
npm
Packages
bootstrap-multiselect
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-352, CWE-79
Reviewed
2025-05-15

Affected packages

• npm bootstrap-multiselect: < 2.0.0 → fixed in 2.0.0

Description

An issue was discovered in post.php in bootstrap-multiselect (aka Bootstrap Multiselect) 1.1.2. A PHP script in the source code echoes arbitrary POST data. If a developer adopts this structure wholesale in a live application, it could create a Reflective Cross-Site Scripting (XSS) vulnerability exploitable through Cross-Site Request Forgery (CSRF).

Related

Alias · CVE (1)

  • CVE-2025-47204 An issue was discovered in post.php in bootstrap-multiselect (aka Bootstrap Multiselect) 1.1.2. vulnerability

Weakness · CWE (2)

  • CWE-352 Cross-Site Request Forgery weakness
  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References