GitHub Advisoryadvisory · Packagist

GHSA-gwwq-54qp-9pgp Zend Framework CSRF Vulnerability

HIGH Published 2022-05-17 Modified 2023-08-03 Official page ↗
Aliases
CVE-2015-1786
Ecosystem
Packagist
Packages
zendframework/zendframework
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2023-08-03

Affected packages

• Packagist zendframework/zendframework: >= 2.3.0, < 2.3.6 → fixed in 2.3.6

Description

Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token identifiers.

Related

Alias · CVE (1)

  • CVE-2015-1786 Cross-site request forgery (CSRF) vulnerability in Zend/Validator/Csrf in Zend Framework 2.3.x before 2.3.6 via null or malformed token… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References