GitHub Advisoryadvisory · Maven

GHSA-gx2j-5vc3-3794 Jenkins Code Dx Plugin cross-site request forgery vulnerability

MEDIUM Published 2023-05-16 Modified 2023-05-17 Official page ↗
Aliases
CVE-2023-2195
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:codedx
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-352
Reviewed
2023-05-17

Affected packages

• Maven org.jenkins-ci.plugins:codedx: < 4.0.0 → fixed in 4.0.0

Description

Jenkins Code Dx Plugin 3.1.0 and earlier does not perform permission checks in several HTTP endpoints. This allows attackers with Overall/Read permission to connect to an attacker-specified URL. Additionally, these HTTP endpoints do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Code Dx Plugin 4.0.0 requires POST requests and the appropriate permissions for the affected HTTP endpoints.

Related

Alias · CVE (1)

  • CVE-2023-2195 A cross-site request forgery (CSRF) vulnerability in Jenkins Code Dx Plugin 3.1.0 and earlier allows attackers to connect to an… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References