GitHub Advisoryadvisory · RubyGems, Maven

GHSA-gx69-6cp4-hxrj RubyGems Link Following vulnerability

HIGH Published 2022-05-13 Modified 2023-03-08 Official page ↗
Aliases
CVE-2018-1000073
Ecosystem
RubyGems, Maven
Packages
rubygems-update, org.jruby:jruby-stdlib
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-59
Reviewed
2023-03-08

Affected packages

• RubyGems rubygems-update: < 2.7.6 → fixed in 2.7.6 • Maven org.jruby:jruby-stdlib: < 9.1.16.0 → fixed in 9.1.16.0

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in `install_location` function of `package.rb` that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

Related

Alias · CVE (1)

  • CVE-2018-1000073 RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5… vulnerability

Weakness · CWE (1)

  • CWE-59 Improper Link Resolution Before File Access weakness

References