GitHub Advisoryadvisory · Packagist
GHSA-gxxq-fhc7-3jv9 Drupal Cross-Site Request Forgery (CSRF)
HIGH
Official page ↗
- Aliases
- CVE-2017-6379
- Ecosystem
- Packagist
- Packages
- drupal/core, drupal/drupal
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2024-04-23
Affected packages
• Packagist drupal/core: >= 8.2.0, < 8.2.7 → fixed in 8.2.7
• Packagist drupal/drupal: >= 8.2.0, < 8.2.7 → fixed in 8.2.7
Description
Some administrative paths in Drupal 8.2.x before 8.2.7 did not include protection for CSRF. This would allow an attacker to disable some blocks on a site. This issue is mitigated by the fact that users would have to know the block ID.
Related
Alias · CVE (1)
- CVE-2017-6379 Some administrative paths in Drupal 8.2.x before 8.2.7 did not include protection for CSRF. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6379 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6379.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6379.yaml web
- https://github.com/drupal/core package
- https://www.drupal.org/SA-2017-001 web
- http://www.securityfocus.com/bid/96919 web
- http://www.securitytracker.com/id/1038058 web