GitHub Advisoryadvisory · Maven

GHSA-h2fw-rfh5-95r3 Apache Tomcat - CGI security constraint bypass

LOW Published 2025-05-29 Modified 2025-11-03 Official page ↗
Aliases
CVE-2025-46701
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U/U:Clear
Weaknesses
CWE-178
Reviewed
2025-05-29

Affected packages

• Maven org.apache.tomcat:tomcat-catalina: >= 9.0.0.M1, < 9.0.105 → fixed in 9.0.105 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.41 → fixed in 10.1.41 • Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.7 → fixed in 11.0.7 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0.M1, < 9.0.105 → fixed in 9.0.105 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.41 → fixed in 10.1.41 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.7 → fixed in 11.0.7 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, <= 8.5.100 (no fix yet)

Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-46701 Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security… vulnerability

Weakness · CWE (1)

  • CWE-178 Improper Handling of Case Sensitivity weakness

References