GitHub Advisoryadvisory · PyPI

GHSA-h574-6646-vfxx Apache Airflow: Ignored Airflow Permission

MEDIUM Published 2024-03-14 Modified 2024-05-02 Official page ↗
Aliases
CVE-2024-28746
Ecosystem
PyPI
Packages
apache-airflow
Severity
Moderate
Weaknesses
CWE-281
Reviewed
2024-03-15

Affected packages

• PyPI apache-airflow: >= 2.8.0, < 2.8.3rc1 → fixed in 2.8.3rc1

Description

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.  Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Related

Alias · CVE (1)

  • CVE-2024-28746 Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access… vulnerability

Weakness · CWE (1)

  • CWE-281 Improper Preservation of Permissions weakness

References