GitHub Advisoryadvisory · Packagist

GHSA-h75f-hjcr-cvh8 Moodle multiple cross-site request forgery (CSRF) vulnerabilities

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-0213
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-352
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.4.10 → fixed in 2.4.10 • Packagist moodle/moodle: >= 2.5.0, < 2.5.6 → fixed in 2.5.6 • Packagist moodle/moodle: >= 2.6.0, < 2.6.3 → fixed in 2.6.3

Description

Multiple cross-site request forgery (CSRF) vulnerabilities in mod/assign/locallib.php in the Assignment subsystem in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allow remote attackers to hijack the authentication of teachers for quick-grading requests.

Related

Alias · CVE (1)

  • CVE-2014-0213 Multiple cross-site request forgery (CSRF) vulnerabilities in mod/assign/locallib.php in the Assignment subsystem in Moodle through 2.3.11,… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References