GitHub Advisoryadvisory · Packagist

GHSA-h77r-rp97-7rv4 Privilage Escalation in moodle

HIGH Published 2021-03-29 Modified 2021-10-20 Official page ↗
Aliases
CVE-2020-25699
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-269, CWE-863
Reviewed
2021-03-24

Affected packages

• Packagist moodle/moodle: >= 3.9.0, < 3.9.3 → fixed in 3.9.3 • Packagist moodle/moodle: >= 3.8.0, < 3.8.6 → fixed in 3.8.6 • Packagist moodle/moodle: >= 3.7.0, < 3.7.9 → fixed in 3.7.9 • Packagist moodle/moodle: >= 3.5, < 3.5.15 → fixed in 3.5.15

Description

In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Related

Alias · CVE (1)

  • CVE-2020-25699 In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles… vulnerability

Weakness · CWE (2)

  • CWE-269 Improper Privilege Management weakness
  • CWE-863 Incorrect Authorization weakness

References