GitHub Advisoryadvisory · RubyGems
GHSA-h8hx-2c5r-32cf Cross-Site Request Forgery (CSRF) in trestle-auth
HIGH
Official page ↗
- Aliases
- CVE-2021-29435
- Ecosystem
- RubyGems
- Packages
- trestle-auth
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2021-04-13
Affected packages
• RubyGems trestle-auth: >= 0.4.0, < 0.4.2 → fixed in 0.4.2
Description
Impact
A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials.
Patches
The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.
For more information
If you have any questions or comments about this advisory:
• Open an issue in trestle-auth
• Email the maintainer at [email protected]
Related
Alias · CVE (1)
- CVE-2021-29435 trestle-auth is an authentication plugin for the Trestle admin framework. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://github.com/TrestleAdmin/trestle-auth/security/advisories/GHSA-h8hx-2c5r-32cf web
- https://nvd.nist.gov/vuln/detail/CVE-2021-29435 advisory
- https://github.com/TrestleAdmin/trestle-auth/commit/cb95b05cdb2609052207af07b4b8dfe3a23c11dc web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/trestle-auth/CVE-2021-29435.yml web
- https://rubygems.org/gems/trestle-auth web