GitHub Advisoryadvisory · Maven

GHSA-hh8r-75r6-qrg9 Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters

HIGH Published 2026-07-06 Modified 2026-08-28 Official page ↗
Aliases
CVE-2026-49042
Ecosystem
Maven
Packages
org.apache.camel:camel-langchain4j-tools, org.apache.camel:camel-langchain4j-agent, org.apache.camel:camel-spring-ai-tools
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20
Reviewed
2026-08-28

Affected packages

• Maven org.apache.camel:camel-langchain4j-tools: >= 4.8.0, < 4.18.3 → fixed in 4.18.3 • Maven org.apache.camel:camel-langchain4j-tools: >= 4.19.0, < 4.21.0 → fixed in 4.21.0 • Maven org.apache.camel:camel-langchain4j-agent: >= 4.8.0, < 4.18.3 → fixed in 4.18.3 • Maven org.apache.camel:camel-langchain4j-agent: >= 4.19.0, < 4.21.0 → fixed in 4.21.0 • Maven org.apache.camel:camel-spring-ai-tools: >= 4.8.0, < 4.18.3 → fixed in 4.18.3 • Maven org.apache.camel:camel-spring-ai-tools: >= 4.19.0, < 4.21.0 → fixed in 4.21.0

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-49042 Improper Input Validation vulnerability in Apache Camel. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References