GitHub Advisoryadvisory · PyPI

GHSA-hhm3-48h2-597v Insufficiently Protected Credentials in Apache Superset

HIGH Published 2022-02-02 Modified 2024-11-18 Official page ↗
Aliases
CVE-2021-44451
Ecosystem
PyPI
Packages
apache-superset
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-522
Reviewed
2022-02-03

Affected packages

• PyPI apache-superset: < 1.4.0 → fixed in 1.4.0

Description

Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.

Related

Alias · CVE (1)

  • CVE-2021-44451 Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. vulnerability

Weakness · CWE (1)

  • CWE-522 Insufficiently Protected Credentials weakness

References