GitHub Advisoryadvisory · Packagist

GHSA-hhq7-jf2p-hw9c Moodle multiple cross-site request forgery (CSRF) vulnerabilities

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-0213
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-352
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.7 → fixed in 2.6.7 • Packagist moodle/moodle: >= 2.7.0, < 2.7.4 → fixed in 2.7.4 • Packagist moodle/moodle: >= 2.8.0, < 2.8.2 → fixed in 2.8.2

Description

Multiple cross-site request forgery (CSRF) vulnerabilities in (1) editcategories.html and (2) editcategories.php in the Glossary module in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allow remote attackers to hijack the authentication of unspecified victims.

Related

Alias · CVE (1)

  • CVE-2015-0213 Multiple cross-site request forgery (CSRF) vulnerabilities in (1) editcategories.html and (2) editcategories.php in the Glossary module in… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References