GitHub Advisoryadvisory · Packagist
GHSA-hqgj-4396-hmxv Magento Open Source allows Cross-Site Request Forgery (CSRF)
MEDIUM
Official page ↗
- Aliases
- CVE-2024-20718
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2025-03-04
Affected packages
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p4 → fixed in 2.4.6-p4
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p6 → fixed in 2.4.5-p6
• Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p7 → fixed in 2.4.4-p7
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a Cross-Site Request Forgery (CSRF) vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to trick a victim into performing actions they did not intend to do, which could be used to bypass security measures and gain unauthorized access. Exploitation of this issue requires user interaction, typically in the form of the victim clicking a link or visiting a malicious website.
Related
Alias · CVE (1)
- CVE-2024-20718 Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a Cross-Site Request Forgery (CSRF) vulnerability that… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness