GitHub Advisoryadvisory · Maven

GHSA-j288-q9x7-2f5v Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs

MEDIUM Published 2025-07-11 Modified 2025-11-05 Official page ↗
Aliases
CVE-2025-48924
Ecosystem
Maven
Packages
org.apache.commons:commons-lang3, commons-lang:commons-lang
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-674
Reviewed
2025-07-12

Affected packages

• Maven org.apache.commons:commons-lang3: >= 3.0, < 3.18.0 → fixed in 3.18.0 • Maven commons-lang:commons-lang: >= 2.0, <= 2.6 (no fix yet)

Description

Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-48924 Uncontrolled Recursion vulnerability in Apache Commons Lang. vulnerability

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References