GitHub Advisoryadvisory · Maven
GHSA-j365-62px-vjjv Jenkins GitLab Plugin Cross-Site Request Forgery vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-10300
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:gitlab-plugin
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2023-10-26
Affected packages
• Maven org.jenkins-ci.plugins:gitlab-plugin: < 1.5.12 → fixed in 1.5.12
Description
Jenkins GitLab Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability.
This form validation method now requires POST requests and Overall/Administer permissions.
Related
Alias · CVE (1)
- CVE-2019-10300 A cross-site request forgery vulnerability in Jenkins GitLab Plugin 1.5.11 and earlier in the GitLabConnectionConfig#doTestConnection form… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness