GitHub Advisoryadvisory · Packagist

GHSA-j586-cj67-vg4p Cross-Site Request Forgery in Drupal core

MEDIUM Published 2022-02-12 Modified 2022-02-23 Official page ↗
Aliases
CVE-2020-13674
Ecosystem
Packagist
Packages
drupal/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Weaknesses
CWE-352
Reviewed
2022-02-23

Affected packages

• Packagist drupal/core: >= 8.0.0, < 8.9.19 → fixed in 8.9.19 • Packagist drupal/core: >= 9.1.0, < 9.1.13 → fixed in 9.1.13 • Packagist drupal/core: >= 9.2.0, < 9.2.6 → fixed in 9.2.6

Description

The QuickEdit module does not properly validate access to routes, which could allow cross-site request forgery under some circumstances and lead to possible data integrity issues. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed. Removing the "access in-place editing" permission from untrusted users will not fully mitigate the vulnerability.

Related

Alias · CVE (1)

  • CVE-2020-13674 The QuickEdit module does not properly validate access to routes, which could allow cross-site request forgery under some circumstances and… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References