GitHub Advisoryadvisory · npm

GHSA-j5c2-hm46-wp5c Privilege escalation: all users can access Admin-level API keys

MEDIUM Published 2021-07-22 Modified 2021-09-03 Official page ↗
Aliases
CVE-2021-39192
Ecosystem
npm
Packages
ghost
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-200, CWE-269
Reviewed
2021-07-20

Affected packages

• npm ghost: >= 4.0.0, < 4.10.0 → fixed in 4.10.0

Description

Impact An error in the implementation of the limits service in 4.0.0 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. Ghost(Pro) has already been patched. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.9.4. Immediate action should be taken to secure your site - see patches & workarounds below. It is highly recommended to regenerate all API keys after patching or applying the workaround below. Patches Fixed in 4.10.0, all 4.x sites should upgrade as soon as possible. Workarounds • Disable all non-Administrator accounts to prevent API access. For more information If you have any questions or comments about this advisory: • email us at [email protected] --- Credits: Aden Yap Chuen Zhen, BAE Systems Applied Intelligence (Malaysia)

Related

Alias · CVE (1)

  • CVE-2021-39192 Ghost is a Node.js content management system. vulnerability

Weakness · CWE (2)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
  • CWE-269 Improper Privilege Management weakness

References