GitHub Advisoryadvisory · Maven
GHSA-jf9j-hx2j-m9xh CSRF vulnerability in Jenkins Database Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2240
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:database
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-21
Affected packages
• Maven org.jenkins-ci.plugins:database: < 1.7 → fixed in 1.7
Description
Database Plugin 1.6 and earlier does not require POST requests for the database console, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to execute arbitrary SQL scripts.
Database Plugin 1.7 removes the database console.
Related
Alias · CVE (1)
- CVE-2020-2240 A cross-site request forgery (CSRF) vulnerability in Jenkins database Plugin 1.6 and earlier allows attackers to execute arbitrary SQL… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2240 advisory
- https://github.com/jenkinsci/database-plugin/commit/a68258cf17ba8d5264010cc760770a62a3cc6c2d web
- https://github.com/jenkinsci/database-plugin package
- https://jenkins.io/security/advisory/2020-09-01/#SECURITY-1023 web
- http://www.openwall.com/lists/oss-security/2020/09/01/3 web