GitHub Advisoryadvisory · Maven
GHSA-jjch-7g85-4m72 Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Cross-Site Request Forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2022-41227
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:cavisson-ns-nd-integration
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-09-23
Affected packages
• Maven io.jenkins.plugins:cavisson-ns-nd-integration: < 4.8.0.130 → fixed in 4.8.0.130
Description
A cross-site request forgery (CSRF) vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers to connect to an attacker-specified webserver using attacker-specified credentials. Version 4.8.0.130 requires POST requests and Overall/Administer permission for the affected form validation method.
Related
Alias · CVE (1)
- CVE-2022-41227 A cross-site request forgery (CSRF) vulnerability in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness