GitHub Advisoryadvisory · PyPI
GHSA-jq57-3w7p-vwvv Docassemble unauthorized access through URL manipulation
HIGH
Official page ↗
- Aliases
- CVE-2024-27292
- Ecosystem
- PyPI
- Packages
- docassemble.webapp, docassemble.base
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-706
- Reviewed
- 2024-02-29
Affected packages
• PyPI docassemble.webapp: >= 1.4.53, < 1.4.97 → fixed in 1.4.97
• PyPI docassemble.base: >= 1.4.53, < 1.4.97 → fixed in 1.4.97
Description
Impact
The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96.
Patches
The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched.
Workarounds
If upgrading is not possible, manually apply the changes of 97f77dc and restart the server.
Credit
The vulnerability was discovered by Riyush Ghimire (@richighimi).
For more information
If you have any questions or comments about this advisory:
• Open an issue in docassemble
• Join the Slack channel
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2024-27292 Docassemble is an expert system for guided interviews and document assembly. vulnerability
Weakness · CWE (1)
- CWE-706 Use of Incorrectly-Resolved Name or Reference weakness