GitHub Advisoryadvisory · Go
GHSA-jqpm-wf57-qx5c Weaviate has an Improper Authorization issue
LOW
Official page ↗
- Aliases
- CVE-2026-11500
- Ecosystem
- Go
- Packages
- github.com/weaviate/weaviate
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-285
- Reviewed
- 2026-07-29
Affected packages
• Go github.com/weaviate/weaviate: < 1.38.0-rc.0 → fixed in 1.38.0-rc.0
Description
A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.
Related
Alias · CVE (1)
- CVE-2026-11500 A vulnerability was identified in Weaviate up to 1.37.7. vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-11500 advisory
- https://github.com/weaviate/weaviate/issues/11392 web
- https://github.com/weaviate/weaviate/commit/40f2cc32279f0f8a51016c3c6870a2c0c808e6c0 web
- https://github.com/weaviate/weaviate package
- https://github.com/weaviate/weaviate/releases/tag/v1.38.0-rc.0 web
- https://vuldb.com/cve/CVE-2026-11500 web
- https://vuldb.com/submit/835080 web
- https://vuldb.com/vuln/369120 web
- https://vuldb.com/vuln/369120/cti web