GitHub Advisoryadvisory · npm
GHSA-jx6q-fq9h-6g7q Pedroetb TTS-API OS Command Injection
CRITICAL
Official page ↗
- Aliases
- CVE-2019-25158
- Ecosystem
- npm
- Packages
- tts-api
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
- Reviewed
- 2023-12-19
Affected packages
• npm tts-api: < 2.2.0 → fixed in 2.2.0
Description
A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.
Related
Alias · CVE (1)
- CVE-2019-25158 A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-25158 advisory
- https://github.com/pedroetb/tts-api/commit/29d9c25415911ea2f8b6de247cb5c4607d13d434 web
- https://github.com/pedroetb/tts-api package
- https://github.com/pedroetb/tts-api/releases/tag/v2.2.0 web
- https://vuldb.com/?ctiid.248278 web
- https://vuldb.com/?id.248278 web