GitHub Advisoryadvisory · Maven
GHSA-jxr6-7qg5-8wv6 OpenNMS Meridian and Horizon vulnerable to Cross-Site Request Forgery
MEDIUM
Official page ↗
- Aliases
- CVE-2023-0870
- Ecosystem
- Maven
- Packages
- org.opennms:opennms-webapp
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-03-22
Affected packages
• Maven org.opennms:opennms-webapp: < 31.0.6 → fixed in 31.0.6
Description
A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Related
Alias · CVE (1)
- CVE-2023-0870 A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness