GitHub Advisoryadvisory · Go
GHSA-m3q4-7qmj-657m OpenFGA Authorization Bypass
HIGH
Official page ↗
- Aliases
- CVE-2022-23542
- Ecosystem
- Go
- Packages
- github.com/openfga/openfga
- Severity
- High
- Weaknesses
- CWE-285
- Reviewed
- 2022-12-20
Affected packages
• Go github.com/openfga/openfga: >= 0.3.0, < 0.3.1 → fixed in 0.3.1
Description
Overview
During our internal security assessment, it was discovered that OpenFGA versions v0.3.0 is vulnerable to authorization bypass under certain conditions.
Am I Affected?
You are affected by this vulnerability if all of the following applies:
1. You are using OpenFGA v0.3.0
2. You created a model using modeling language v1.1 that applies a type restriction to an object e.g. `define viewer: [user]`
3. You created tuples based on the aforementioned model, e.g. `document:1#viewer@user:jon`
4. You updated the previous model by adding a new type and replacing the previous restriction with the newly added type e.g. `define viewer: [employee]`
5. You use the tuples created against the first model (step 3) and issue checks against the updated model e.g. `user=user:jon, relation=viewer, object:document:1`
How to fix that?
Upgrade to version v0.3.1
Backward Compatibility
This update is backward compatible.
Related
Alias · CVE (1)
- CVE-2022-23542 OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness