GitHub Advisoryadvisory · Maven
GHSA-m5cw-c64p-77h6 CSRF vulnerability in Jenkins Subversion Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-29048
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:subversion
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-01
Affected packages
• Maven org.jenkins-ci.plugins:subversion: < 2.15.4 → fixed in 2.15.4
Description
Subversion Plugin 2.15.3 and earlier does not require POST requests for several form validation methods, resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to connect to an attacker-specified URL.
Related
Alias · CVE (1)
- CVE-2022-29048 A cross-site request forgery (CSRF) vulnerability in Jenkins Subversion Plugin 2.15.3 and earlier allows attackers to connect to an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-29048 advisory
- https://github.com/jenkinsci/subversion-plugin/commit/882a7d359f6ac73c53d787bff4d62eba837001ea web
- https://github.com/jenkinsci/subversion-plugin package
- https://support.apple.com/kb/HT213345 web
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2075 web
- http://seclists.org/fulldisclosure/2022/Jul/18 web