GitHub Advisoryadvisory · Packagist

GHSA-m8qh-hx4c-h9hr Moodle has a CSRF risk in Brickfield tool's analysis request action

LOW Published 2025-04-25 Modified 2025-04-25 Official page ↗
Aliases
CVE-2025-3638
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-352
Reviewed
2025-04-25

Affected packages

• Packagist moodle/moodle: < 4.1.18 → fixed in 4.1.18 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4

Description

A flaw was found in Moodle. The analysis request action in the Brickfield tool did not include the necessary token to prevent a Cross-site request forgery (CSRF) risk.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References