GitHub Advisoryadvisory · PyPI

GHSA-mcmc-2m55-j8jj vLLM introduced enhanced protection for CVE-2025-62164

HIGH Published 2026-01-08 Modified 2026-09-11 Official page ↗
Aliases
CVE-2026-56340
Ecosystem
PyPI
Packages
vllm
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-123, CWE-20, CWE-502, CWE-787
Reviewed
2026-01-08

Affected packages

• PyPI vllm: >= 0.10.2, < 0.13.0 → fixed in 0.13.0

Description

Summary The fix here for CVE-2025-62164 is not sufficient. The fix only disables prompt embeds by default rather than addressing the root cause, so the DoS vulnerability remains when the feature is enabled. Details vLLM's pending change attempts to fix the root cause, which is the missing sparse tensor validation. PyTorch (~v2.0) disables sparse tensor validation (specifically, sparse tensor invariants checks) by default for performance reasons. vLLM is adding the sparse tensor validation to ensure indices are valid, non-negative, and within bounds. These checks help catch malformed tensors. PoC NA Impact Current fix only added a flag to disable/enable prompt embeds, so by default, prompt embeds feature is disabled in vLLM, which stops DoS attacks through the embeddings. However, It doesn’t address the problem when the flag is enabled and there is still potential for DoS attacks. Changes • https://github.com/vllm-project/vllm/pull/30649

Related

Alias · CVE (1)

  • CVE-2026-56340 vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. vulnerability

Weakness · CWE (4)

  • CWE-123 Write-what-where Condition weakness
  • CWE-20 Improper Input Validation weakness
  • CWE-502 Deserialization of Untrusted Data weakness
  • CWE-787 Out-of-bounds Write weakness

References