GitHub Advisoryadvisory · Maven
GHSA-mgp5-rv84-w37q Apache Tomcat has an Improper Input Validation vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2026-24734
- Ecosystem
- Maven
- Packages
- org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2026-03-19
Affected packages
• Maven org.apache.tomcat:tomcat-coyote: >= 11.0.0-M1, < 11.0.18 → fixed in 11.0.18
• Maven org.apache.tomcat:tomcat-coyote: >= 10.1.0-M7, < 10.1.52 → fixed in 10.1.52
• Maven org.apache.tomcat:tomcat-coyote: >= 9.0.83, < 9.0.115 → fixed in 9.0.115
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.18 → fixed in 11.0.18
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M7, < 10.1.52 → fixed in 10.1.52
• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.83, < 9.0.115 → fixed in 9.0.115
Description
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.
When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed.
This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114.
The following versions were EOL at the time the CVE was created but are
known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected.
Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue.
Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
Related
Alias · CVE (1)
- CVE-2026-24734 Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness