GitHub Advisoryadvisory · PyPI

GHSA-mjff-wv85-hmcj Apache Airflow vulnerable to exposure of sensitive information

HIGH Published 2023-06-19 Modified 2024-11-18 Official page ↗
Aliases
CVE-2023-35005
Ecosystem
PyPI
Packages
apache-airflow
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2023-06-19

Affected packages

• PyPI apache-airflow: >= 2.5.0, < 2.6.2rc1 → fixed in 2.6.2rc1

Description

In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.

Related

Alias · CVE (1)

  • CVE-2023-35005 In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References