GitHub Advisoryadvisory · Maven
GHSA-mm5c-7mpr-99fm CSRF vulnerability in Jenkins Libvirt Agents Plugin
HIGH
Official page ↗
- Aliases
- CVE-2021-21627
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:libvirt-slave
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-14
Affected packages
• Maven org.jenkins-ci.plugins:libvirt-slave: < 1.9.1 → fixed in 1.9.1
Description
Jenkins Libvirt Agents Plugin 1.9.0 and earlier does not require POST requests for a form submission endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to stop hypervisor domains.
Jenkins Libvirt Agents Plugin 1.9.1 requires POST requests for the affected HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2021-21627 A cross-site request forgery (CSRF) vulnerability in Jenkins Libvirt Agents Plugin 1.9.0 and earlier allows attackers to stop hypervisor… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21627 advisory
- https://github.com/jenkinsci/libvirt-slave-plugin/commit/655eab9bde26e8b8e11034f6c405af374564cae7 web
- https://github.com/jenkinsci/libvirt-slave-plugin package
- https://www.jenkins.io/security/advisory/2021-03-18/#SECURITY-1764 web
- http://www.openwall.com/lists/oss-security/2021/03/18/5 web