GitHub Advisoryadvisory · Maven

GHSA-mmrv-3cqg-hpf9 Sandbox Bypass via CSRF in Jenkins Warnings Plugin

HIGH Published 2022-05-13 Modified 2024-01-30 Official page ↗
Aliases
CVE-2019-1003007
Ecosystem
Maven
Packages
org.jvnet.hudson.plugins:warnings
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2024-01-30

Affected packages

• Maven org.jvnet.hudson.plugins:warnings: < 5.0.1 → fixed in 5.0.1

Description

A cross-site request forgery vulnerability exists in Jenkins Warnings Plugin 5.0.0 and earlier in src/main/java/hudson/plugins/warnings/GroovyParser.java that allows attackers to execute arbitrary code via a form validation HTTP endpoint.

Related

Alias · CVE (1)

  • CVE-2019-1003007 A cross-site request forgery vulnerability exists in Jenkins Warnings Plugin 5.0.0 and earlier in… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References