GitHub Advisoryadvisory · Maven

GHSA-mpv3-g527-fqrj Cloud Foundry Runtime Cross-Site Request Forgery vulnerability

HIGH Published 2022-05-13 Modified 2024-02-28 Official page ↗
Aliases
CVE-2015-5170
Ecosystem
Maven
Packages
org.cloudfoundry.identity:cloudfoundry-identity-server
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2024-02-28

Affected packages

• Maven org.cloudfoundry.identity:cloudfoundry-identity-server: < 2.5.2 → fixed in 2.5.2

Description

Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.7.0 allow remote attackers to conduct cross-site request forgery (CSRF) attacks on PWS and log a user into an arbitrary account by leveraging lack of CSRF checks.

Related

Alias · CVE (1)

  • CVE-2015-5170 Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.7.0 allow remote… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References