GitHub Advisoryadvisory · npm
GHSA-mr6f-h57v-rpj5 Improper Validation of Query Parameters in Auth0 Next.js SDK
LOW
Official page ↗
- Aliases
- CVE-2025-67716
- Ecosystem
- npm
- Packages
- @auth0/nextjs-auth0
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-184
- Reviewed
- 2025-12-10
Affected packages
• npm @auth0/nextjs-auth0: >= 4.9.0, < 4.13.0 → fixed in 4.13.0
Description
Description
An input-validation flaw in the returnTo parameter in the Auth0 Next.js SDK could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters
Am I Affected?
You are affected if you meet the following preconditions:
• Applications using the auth0/nextjs-auth0 SDK version prior to 4.13.0
Affected product and versions
Auth0/nextjs-auth0 versions >= 4.9.0 and < 4.13.0
Resolution
Upgrade Auth0/nextjs-auth0 version to v4.13.0
Acknowledgements
Okta would like to thank Joshua Rogers (MegaManSec) for their discovery and responsible disclosure.
Related
Alias · CVE (1)
- CVE-2025-67716 The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. vulnerability
Weakness · CWE (1)
- CWE-184 Incomplete List of Disallowed Inputs weakness