GitHub Advisoryadvisory · PyPI

GHSA-mrw7-hf4f-83pf vLLM deserialization vulnerability leading to DoS and potential RCE

HIGH Published 2025-11-20 Modified 2026-07-17 Official page ↗
Aliases
CVE-2025-62164
Ecosystem
PyPI
Packages
vllm
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-123, CWE-20, CWE-502, CWE-787
Reviewed
2025-11-20

Affected packages

• PyPI vllm: >= 0.10.2, < 0.11.1 → fixed in 0.11.1

Description

Summary A memory corruption vulnerability that leading to a crash (denial-of-service) and potentially remote code execution (RCE) exists in vLLM versions 0.10.2 and later, in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. Details A vulnerability that can lead to RCE from the completions API endpoint exists in vllm, where due to missing checks when loading user-provided tensors, an out-of-bounds write can be triggered. This happens because the default behavior of `torch.load(tensor, weights_only=True)` since pytorch 2.8.0 is to not perform validity checks for sparse tensors, and this needs to be enabled explicitly using the torch.sparse.check_sparse_tensor_invariants context manager. The vulnerability is in the following code in vllm/entrypoints/renderer.py:148 ```python def _load_and_validate_embed(embed: bytes) -> EngineEmbedsPrompt: tensor = torch.load( io.BytesIO(pybase64.b64decode(embed, validate=True)), weights_only=True, map_location=torch.device("cpu"), ) assert isinstance(tensor, torch.Tensor) and tensor.dtype in ( torch.float32, torch.bfloat16, torch.float16, ) tensor = tensor.to_dense() ``` Because of the missing checks, loading invalid prompt embedding tensors provided by the user can cause an out-of-bounds write in the call to `to_dense` . Impact All users with access to this API are able to exploit this vulnerability. Unsafe deserialization of untrusted input can be abused to achieve DoS and potentially remote code execution (RCE) in the vLLM server process. This impacts deployments running vLLM as a server or any instance that deserializes untrusted/model-provided payloads. Fix https://github.com/vllm-project/vllm/pull/27204 Acknowledgements Finder: AXION Security Research Team (Omri Fainaro, Bary Levy): discovery and coordinated disclosure.

Related

Alias · CVE (1)

  • CVE-2025-62164 vLLM is an inference and serving engine for large language models (LLMs). vulnerability

Weakness · CWE (4)

  • CWE-123 Write-what-where Condition weakness
  • CWE-20 Improper Input Validation weakness
  • CWE-502 Deserialization of Untrusted Data weakness
  • CWE-787 Out-of-bounds Write weakness

References