GitHub Advisoryadvisory · PyPI

GHSA-mvfq-ggxm-9mc5 Django vulnerable to ASGI header spoofing via underscore/hyphen conflation

HIGH Published 2026-04-07 Modified 2026-06-05 Official page ↗
Aliases
CVE-2026-3902
Ecosystem
PyPI
Packages
Django
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-290
Reviewed
2026-04-08

Affected packages

• PyPI Django: >= 6.0, < 6.0.4 → fixed in 6.0.4 • PyPI Django: >= 5.2, < 5.2.13 → fixed in 5.2.13 • PyPI Django: >= 4.2, < 4.2.30 → fixed in 4.2.30

Description

An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30. `ASGIRequest` allows a remote attacker to spoof headers by exploiting an ambiguous mapping of two header variants (with hyphens or with underscores) to a single version with underscores. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Tarek Nakkouch for reporting this issue.

Related

Alias · CVE (1)

  • CVE-2026-3902 An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30. vulnerability

Weakness · CWE (1)

  • CWE-290 Authentication Bypass by Spoofing weakness

References