GitHub Advisoryadvisory · Maven

GHSA-mvgm-3rw2-7j4r org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type

CRITICAL Published 2025-04-29 Modified 2025-04-30 Official page ↗
Aliases
CVE-2025-32974
Ecosystem
Maven
Packages
org.xwiki.platform:xwiki-platform-security-requiredrights-default
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-116, CWE-269
Reviewed
2025-04-29

Affected packages

• Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default: >= 15.9-rc-1, < 15.10.8 → fixed in 15.10.8 • Maven org.xwiki.platform:xwiki-platform-security-requiredrights-default: >= 16.0.0-rc-1, < 16.2.0 → fixed in 16.2.0

Description

Impact When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. To reproduce, as a user without script right, create a class with a `TextArea` property, create page with an object of that class and a Velocity macro in its content. Then, as an admin, try editing that page. Normally, there should be a warning but in vulnerable versions of XWiki, there is no warning. Patches This vulnerability has been patched in XWiki 15.10.8 and 16.2.0. Workarounds We're not aware of any workarounds apart from not editing pages that might have been edited by untrusted users as a user with script rights, e.g., by using separate user accounts for admin and non-admin tasks.

Related

Alias · CVE (1)

Weakness · CWE (2)

  • CWE-116 Improper Encoding or Escaping of Output weakness
  • CWE-269 Improper Privilege Management weakness

References