GitHub Advisoryadvisory · Maven

GHSA-p364-xfp2-f9rr CSRF vulnerability in Jenkins Fortify on Demand Plugin

MEDIUM Published 2022-05-24 Modified 2022-12-28 Official page ↗
Aliases
CVE-2020-2203
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:fortify-on-demand-uploader
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-352
Reviewed
2022-12-28

Affected packages

• Maven org.jenkins-ci.plugins:fortify-on-demand-uploader: < 6.0.0 → fixed in 6.0.0

Description

A cross-site request forgery vulnerability in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs. This form validation method requires appropriate permission in Fortify on Demand Plugin 6.0.0.

Related

Alias · CVE (1)

  • CVE-2020-2203 A cross-site request forgery vulnerability in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers to connect to the… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References