GitHub Advisoryadvisory · npm

GHSA-pfj7-wv7c-22pr Parse Server has an auth provider validation bypass on login via partial authData

HIGH Published 2026-03-19 Modified 2026-03-30 Official page ↗
Aliases
CVE-2026-33409
Ecosystem
npm
Packages
parse-server
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-287
Reviewed
2026-03-19

Affected packages

• npm parse-server: >= 9.0.0, < 9.6.0-alpha.41 → fixed in 9.6.0-alpha.41 • npm parse-server: < 8.6.52 → fixed in 8.6.52

Description

Impact An authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option `allowExpiredAuthDataToken` is set to `true`. The default value is `false`. Patches Auth providers are now always validated on login, regardless of the `allowExpiredAuthDataToken` setting. The option `allowExpiredAuthDataToken` has been deprecated and will be removed in a future major version. Workarounds Set `allowExpiredAuthDataToken` to `false` (the default) or remove the option from the server configuration.

Related

Alias · CVE (1)

  • CVE-2026-33409 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References