GitHub Advisoryadvisory · Maven

GHSA-phjq-7xqp-2526 Jenkins Nexus Platform Plugin Cross-Site Request Forgery vulnerability

MEDIUM Published 2023-12-13 Modified 2023-12-18 Official page ↗
Aliases
CVE-2023-50768
Ecosystem
Maven
Packages
org.sonatype.nexus.ci:nexus-jenkins-plugin
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-352
Reviewed
2023-12-18

Affected packages

• Maven org.sonatype.nexus.ci:nexus-jenkins-plugin: < 3.18.1-01 → fixed in 3.18.1-01

Description

Jenkins Nexus Platform Plugin 3.18.0-03 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Nexus Platform Plugin 3.18.1-01 requires POST requests and Overall/Administer permission for the affected form validation methods.

Related

Alias · CVE (1)

  • CVE-2023-50768 A cross-site request forgery (CSRF) vulnerability in Jenkins Nexus Platform Plugin 3.18.0-03 and earlier allows attackers to connect to an… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References