GitHub Advisoryadvisory · Maven
GHSA-pmmr-r9v2-59p8 Jenkins Reverse Proxy Auth Plugin cross-site request forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-32987
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:reverse-proxy-auth-plugin
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-05-17
Affected packages
• Maven org.jenkins-ci.plugins:reverse-proxy-auth-plugin: < 1.7.5 → fixed in 1.7.5
Description
Jenkins Reverse Proxy Auth Plugin 1.7.4 and earlier does not require POST requests for a form validation method, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to connect to an attacker-specified LDAP server using attacker-specified credentials.
Reverse Proxy Auth Plugin 1.7.5 requires POST requests for the affected form validation method.
Related
Alias · CVE (1)
- CVE-2023-32987 A cross-site request forgery (CSRF) vulnerability in Jenkins Reverse Proxy Auth Plugin 1.7.4 and earlier allows attackers to connect to an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness