GitHub Advisoryadvisory · PyPI

GHSA-pmqf-x6x8-p7qw vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs

HIGH Published 2025-11-20 Modified 2026-07-17 Official page ↗
Aliases
CVE-2025-62372
Ecosystem
PyPI
Packages
vllm
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-129
Reviewed
2025-11-20

Affected packages

• PyPI vllm: >= 0.5.5, < 0.11.1 → fixed in 0.11.1

Description

Summary Users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct `ndim` but incorrect `shape` (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). The issue has existed ever since we added support for image embedding inputs, i.e. #6613 (released in v0.5.5) Details Using image embeddings as an example: • For models that support image embedding inputs, the engine crashes when scattering the embeddings to `inputs_embeds` (mismatched shape) • For models that don't support image embedding inputs, the engine crashes when validating the inputs inside `get_input_embeddings` (validation fails). This happens because we only validate `ndim` of the tensor, but not the full shape, in input processor (via `MultiModalDataParser`). Impact • Denial of service by crashing the engine Mitigation • Use API key to limit access to trusted users. • Set `--limit-mm-per-prompt` to 0 for all non-text modalities to ban multimodal inputs, which includes multimodal embedding inputs. However, the model would then only accept text, defeating the purpose of using a multi-modal model. Resolution • https://github.com/vllm-project/vllm/pull/27204

Related

Alias · CVE (1)

  • CVE-2025-62372 vLLM is an inference and serving engine for large language models (LLMs). vulnerability

Weakness · CWE (1)

  • CWE-129 Improper Validation of Array Index weakness

References