GitHub Advisoryadvisory · npm

GHSA-prfq-f66g-43mp Information disclosure through error object in auth0.js

HIGH Published 2020-04-10 Modified 2021-01-08 Official page ↗
Aliases
CVE-2020-5263
Ecosystem
npm
Packages
auth0-js
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N
Weaknesses
CWE-522
Reviewed
2020-04-09

Affected packages

• npm auth0-js: >= 8.0.0, < 9.13.2 → fixed in 9.13.2

Description

Overview Between versions 8.0.0 and 9.13.1(inclusive), in the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. Am I affected? You are affected by this vulnerability if all of the following conditions apply: • You are using Auth0.js version between 8.0.0 and 9.13.1(inclusive). • You store or display error objects without filtering. How to fix that? Developers should upgrade auth0.js to version 9.13.2 or later where user inputted passwords are masked in errors. If upgrading is not possible, a temporary fix may include not storing the error object or displaying it publicly without modification. Will this update impact my users? This fix patches the Auth0.js and may require changes in application code due to password no longer available in error object, but it will not impact your users, their current state, or any existing sessions.

Related

Alias · CVE (1)

  • CVE-2020-5263 auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. vulnerability

Weakness · CWE (1)

  • CWE-522 Insufficiently Protected Credentials weakness

References