GitHub Advisoryadvisory · Packagist
GHSA-prxr-vjgc-2cq9 Concrete CMS is Vulnerable to Cross-Site Request Forgery
HIGH
Official page ↗
- Aliases
- CVE-2026-8428
- Ecosystem
- Packagist
- Packages
- concrete5/concrete5
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Weaknesses
- CWE-352
- Reviewed
- 2026-06-24
Affected packages
• Packagist concrete5/concrete5: < 9.5.1 → fixed in 9.5.1
Description
Concrete CMS 9.5.0 and below emits a CSRF token in the local_available_update.php view ($token->output('do_update')) but the corresponding do_update() method in concrete/controllers/single_page/dashboard/system/update/update.php never calls $this->token->validate('do_update'). The form is rendered as a POST form, meaning the token reaches the browser, but because the controller discards it without verification, an attacker can craft a cross-site POST that triggers a core CMS update to an attacker-specified version string. In order to be vulnerable, theictim must be passing canUpgrade()anda valid update version must be present under DIR_CORE_UPDATES.
Related
Alias · CVE (1)
- CVE-2026-8428 Concrete CMS 9.5.0 and below emits a CSRF token in the local_available_update.php view ($token->output('do_update')) but the corresponding… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness