GitHub Advisoryadvisory · PyPI

GHSA-pw38-xv9x-h8ch RunGptLLM class in LlamaIndex has a command injection

HIGH Published 2024-05-16 Modified 2024-05-16 Official page ↗
Aliases
CVE-2024-4181
Ecosystem
PyPI
Packages
llama-index, llama-index-llms-rungpt
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2024-05-16

Affected packages

• PyPI llama-index: < 0.10.13 → fixed in 0.10.13 • PyPI llama-index-llms-rungpt: < 0.1.3 → fixed in 0.1.3

Description

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

Related

Alias · CVE (1)

  • CVE-2024-4181 A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References