GitHub Advisoryadvisory · Maven
GHSA-pwvj-6phx-qv8c CSRF vulnerability in Jenkins Translation Assistance plugin
HIGH
Official page ↗
- Aliases
- CVE-2018-1000014
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:translation
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2024-01-30
Affected packages
• Maven org.jenkins-ci.plugins:translation: < 1.16 → fixed in 1.16
Description
Jenkins Translation Assistance Plugin 1.15 and earlier did not require form submissions to be submitted via POST, resulting in a CSRF vulnerability allowing attackers to override localized strings displayed to all users on the current Jenkins instance if the victim is a Jenkins administrator.
Related
Alias · CVE (1)
- CVE-2018-1000014 Jenkins Translation Assistance Plugin 1.15 and earlier did not require form submissions to be submitted via POST, resulting in a CSRF… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness